すぐ消える
nwn -> hcr, cep, prc, hak, etc.
スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
--/--/-- --:--:--| スポンサー広告| trackback(-) comment(-)
変数名の命名規則

変数名の命名規則はもちろん最初から順番に

int a, b, c, aa, bb;

が、笑い話でなく恐怖譚なのがプログラムの世界、私も何度プログラマの悲鳴を聞いたことか…。
ぎゃー。

冗談であって欲しい話は置いといて、命名規則。
命名規則というほどでもないですが、「英語は平易な単語で、何だったらローマ字でもいいではないか。」でしょうか。
英語の辞書を引いて変数・関数名をつけるヒトがいまして、「自分でもわからない単語を使ったら名前の意味ないじゃないか。」と何度か言った覚えが…。

あとコーディングで。
よくあるのが

if(GetLocalInt(oNearest, "RandomWalk") ||
   GetLocalInt(oNearest, "ReturnHome") ||
   GetLocalInt(oNearest, "RandomFacing"))
     SetLocalInt(oNearest, "Spawning",
         GetLocalInt(oNearest, "Spawning") - iSpawnX);

私の場合
if(GetLocalInt(oNearest, "RandomWalk")
   || GetLocalInt(oNearest, "ReturnHome")
   || GetLocalInt(oNearest, "RandomFacing"))
     SetLocalInt(oNearest, "Spawning"
         , GetLocalInt(oNearest, "Spawning") - iSpawnX);

インデントが消えると違いがはっきりと。
if(GetLocalInt(oNearest, "RandomWalk") ||
GetLocalInt(oNearest, "ReturnHome") ||
GetLocalInt(oNearest, "RandomFacing"))
SetLocalInt(oNearest, "Spawning",
GetLocalInt(oNearest, "Spawning") - iSpawnX);

if(GetLocalInt(oNearest, "RandomWalk")
|| GetLocalInt(oNearest, "ReturnHome")
|| GetLocalInt(oNearest, "RandomFacing"))
SetLocalInt(oNearest, "Spawning"
, GetLocalInt(oNearest, "Spawning") - iSpawnX);

インデントが消える・ずれる事故はよく起きるので下のほうが安全に思うけど少数派。

うーむ…参考にならんな…。

スクリプトがMOD作成の壁って話があるけど、アルゴリズムの間違いではないだろうか?

スポンサーサイト
comment
comments
||というのは条件分け(or)ですよね?<ちょっと勉強してきた
なるほど、先頭にあると今何をしているのかがわかりやすくなりますね。
2005/05/22(日) 04:09:39 | URL | geshi #-[ edit]
MOD作成の壁
> 「英語は平易な単語で、何だったらローマ字でもいいではないか。」

そう言ってもらえると、すごく気が楽になりますね(w
変数名を決めるだけで疲れるのは本末転倒な気がしますし。

> スクリプトがMOD作成の壁って話があるけど、アルゴリズムの間違いではないだろうか?

確かにそれも壁だと思いますが、どちらかと言うと、MOD作成してみたけど、意図した通りにスクリプトが組めないって感じですよね?
それより以前に、スクリプトそれ自体への拒否感をやわらげられないかというところからの話になってまして、スクリプト・ジェネレーターの日本語化の流れと同じ話です。
2005/05/22(日) 07:44:14 | URL | e_tacky #43Aor.pI[ edit]
気軽さ
「ちょっとやってみよっかな。」な感じの気軽さが重要ですね。
いろいろな活動が活発になることでその気軽さが出てくるといいですね。
(そこら辺もうちょっとSEGAに…)
2005/05/22(日) 22:36:01 | URL | uwid #fxrXqkow[ edit]
post
url:
comment:
pass:
himitu: 管理者にだけ表示を許可する
 
trackback
trackback url
trackback
昨日の記事「NWNのスクリプト」で、geshiさんから変数について「こういう観点からこういう名前を付けていった方が後々把握しやすくていい、というようなことが気になります」とのコメントを頂きました。この点に関して、あくまで個人的意見として書いてみました。
2005/05/22(日) 07:29:44) | カルシィ村へようこそ!-Neverwinter Nights
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。